Home > Failed To > Failed To Build Native Extension Capybara-webkit

Failed To Build Native Extension Capybara-webkit

Contents

We're currently hooking into the Rubygems hooks for C extensions in order to trigger the compile step. You may need to confirm the license agreement by running /usr/bin/xcodebuild. *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Qt itself seems to work fine, I can run the Qt Creator just fine. –Francois Jan 12 '12 at 20:55 @Francois - please post a separate question with your See for instructions. Source

I noticed that the Wiki does not mention Yosemite. Reload to refresh your session. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 77 Star 1,818 Fork 440 thoughtbot/capybara-webkit Code Issues 74 Pull requests 14 Projects Let me know what other info you would like and I'll provide right away. ➔ gem install capybara-webkit -v '1.4.1' ; alert Building native extensions. official site

Error: Error Installing Capybara-webkit: Error: Failed To Build Gem Native Extension.

Member jferris commented Oct 2, 2015 I'm going to close this issue, as it seems like all of these reports are generally broken build tool installations on OS X. Terms Privacy Security Status Help You can't perform that action at this time. mkmf.rb can't find header files for ruby at /Users/mico/.rbenv/versions/jruby-1.7.21/lib/native/include/ruby/ruby.h extconf failed, uncaught signal 1 jjb commented Aug 17, 2015 I get the same error as @mico. sbeckeriv commented Oct 28, 2014 Short: Thanks! @apecherin thanks!

  1. Also run brew doctor afterwards, to make sure everything is fine.
  2. Reload to refresh your session.
  3. You signed out in another tab or window.
  4. sbeckeriv commented Oct 28, 2014 @apecherin I have g++ pointing to g++-4.2 with no luck.
  5. I don't believe ruby.h or anything similar is necessary; we require the ability to build C++ applications using Qt, which actually has nothing to do with Ruby or C extensions.
  6. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/bundler/issues so that we can fix it.

Uses `poltergeist` instead of `capybara-webkit`. I am all mixed up with brew. I'll create a new app and see if it still works and report back. Capybara-webkit Qt5 The flag is needed as qtwebkit is no longer included in Qt by default.

Collaborator mhoran commented Jul 23, 2015 Hey @EvanHahn. Gem Install Capybara-webkit thebenedict commented Aug 5, 2015 I had to: uninstall qt4 and install qt5 with homebrew brew link --force qt5 bundle uninstall capybara-webkit and then bundle install 👍 4 monfresh commented Sounds like this issues should be closed and moved to Launchpad? Uses `poltergeist` instead of `capybara-webkit`.

I am currently considering experimenting with deleting Xcode now that I have already installed and built capybara-webkit and Qt 5, and see if everything still runs.. 👍 1 Member jferris Error Installing Capybara-webkit Ubuntu Related to [jruby/jruby#3038]. Otherwise compiling will result in precompiled header errors, and the QT_VERSION_CHECK macro will not be found. I've had good luck raising problems via Launchpad in the past.

Gem Install Capybara-webkit

vagrant --version # => Vagrant 1.6.5 Looks like we're on the same version of G++...any thoughts? First update the formulas, then try installing the built binary with: brew update brew install qt If that doesn't work, try building it from source (which can take more than an Error: Error Installing Capybara-webkit: Error: Failed To Build Gem Native Extension. Install Qt 5.5 with homebrew: brew tap homebrew/versions brew install qt55 The Homebrew formula for qt55 is keg only which means binaries like qmake will not be symlinked into your /usr/local/bin Capybara-webkit Gem I have a project that I just upgraded to latest capybara-webkit(1.10.1), and now Travis-CI won't build the project because its saying it has disabled C Extensions.

ERROR: Error installing capybara-webkit: ERROR: Failed to build gem native extension. /Users/tom/.rbenv/versions/2.0.0-p0/bin/ruby extconf.rb Command '/usr/local/opt/qt-4.8/bin/qmake -spec macx-g++ ' not available Gem files will remain installed in /Users/tom/.rbenv/versions/2.0.0-p0/lib/ruby/gems/2.0.0/gems/capybara-webkit-1.1.1 for inspection. http://1pxcare.com/failed-to/failed-to-build-sage-entity-interfaces-dll-sage-platform-orm-codegen.html Collaborator mhoran commented Jul 5, 2015 Yikes. Bash remembers wrong path to an executable that was moved/deleted What does the expression 'seven for seven thirty ' mean? It might depend on your use case. Command 'qmake ' Failed

Im running OSX my_app$ gem install capybara-webkit Building native extensions. brew install qt5 brew link --force qt5 gem install capybara-webkit share|improve this answer answered Jul 12 '16 at 3:48 Frozenna 126212 add a comment| Your Answer draft saved draft discarded Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 77 Star 1,818 Fork 440 thoughtbot/capybara-webkit Code Issues 74 Pull requests 14 Projects http://1pxcare.com/failed-to/failed-to-notify-build-listener.html I have xcode installed, however.

This process is admittedly brittle, and not clear how much longer will be valid. Project Error: Xcode Not Set Up Properly. I use rbenv and I think it does not distribute the header file. Member jferris commented Apr 10, 2015 @mhoran it seems like this isn't a bug.

thanks Marc –eiu165 Dec 3 '11 at 13:47 add a comment| 12 Answers 12 active oldest votes up vote 78 down vote accepted Try installing libqt via homebrew.

Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 77 Star 1,818 Fork 440 thoughtbot/capybara-webkit Code Issues 74 Pull requests 14 Projects Reload to refresh your session. pecha7x commented Oct 28, 2014 @sbeckeriv The other day I deployed a new project and was able compiled only via g++-4.2. Webkit_server Failed To Start. Unfortunately, testing for `jruby` support is impossible until [thoughtbot/capybara-webkit#725][#725] is resolved. [#241]: https://github.com/thoughtbot/ember-cli-rails/pull/241 [spawn]: http://ruby-doc.org/core-2.2.3/Kernel.html#method-i-spawn [jruby/jruby#3038]: https://github.com/jruby/jruby/issues/3038 [#725]: https://github.com/thoughtbot/capybara-webkit/issues/725">Add `jruby-9000` to testing matrix … Closes [#241].

Reload to refresh your session. downneck commented Oct 15, 2014 make sure you install both -devel and -webkit-devel packages Sign up for free to join this conversation on GitHub. Contents of table bigger than the rest of the text and also not centered more hot questions question feed lang-rb about us tour help blog chat data legal privacy policy work http://1pxcare.com/failed-to/failed-to-remove-dlm-extension.html Installing via gem install capybara-webkit ~ @ gem install capybara-webkit Building native extensions.

Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 77 Star 1,818 Fork 440 thoughtbot/capybara-webkit Code Issues 74 Pull requests 14 Projects